ItemText Property


Gets or sets the text displayed on the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual string ItemText { get; set; }
Visual Basic
Public Overridable Property ItemText As String
	Get
	Set
Visual C++
public:
virtual property String^ ItemText {
	String^ get ();
	void set (String^ value);
}

Remarks

The text can be changed at run time. a null reference (Nothing in Visual Basic) or empty string is not allowed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when setting the text to empty or to the string contains "%".
Autodesk.Revit.ExceptionsArgumentNullException Thrown when setting the text to a null reference (Nothing in Visual Basic).

See Also