Replaces a sorting/grouping field.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- index
- Type: SystemInt32
The index of the sorting/grouping field to replace.
- sortGroupField
- Type: Autodesk.Revit.DBScheduleSortGroupField
The new sorting/grouping field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | index is not a valid sorting/grouping field index. |