SetSortGroupField Method


Schedule Definition Set Sort Group Field Method

Replaces a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSortGroupField(
	int index,
	ScheduleSortGroupField sortGroupField
)

Parameters

index Int32
The index of the sorting/grouping field to replace.
sortGroupField ScheduleSortGroupField
The new sorting/grouping field.
Exceptions
Exception Condition
ArgumentException The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException index is not a valid sorting/grouping field index.
See Also