Get the ConceptualSurfaceType by its mass subcategory id.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- cda
- Type: Autodesk.Revit.DBDocument
The document.
- massSubCategoryId
- Type: Autodesk.Revit.DBElementId
The mass subcategory id to get the ConceptualSurfaceType for.
Return Value
Returns ConceptualSurfaceType associated with input id or NULL.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassShade, OST_MassGlazing, OST_MassSkylights, or OST_MassOpening. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |