GetByMassSubCategoryId Method


Conceptual Surface Type Get By Mass Sub Category Id Method

Get the ConceptualSurfaceType by its mass subcategory id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ConceptualSurfaceType GetByMassSubCategoryId(
	Document cda,
	ElementId massSubCategoryId
)

Parameters

cda Document
The document.
massSubCategoryId ElementId
The mass subcategory id to get the ConceptualSurfaceType for.

Return Value

ConceptualSurfaceType
Returns ConceptualSurfaceType associated with input id or NULL.
Exceptions
Exception Condition
ArgumentException The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassShade, OST_MassGlazing, OST_MassSkylights, or OST_MassOpening.
ArgumentNullException A non-optional argument was null
See Also