RemoveControl Method


Deletes the existing control identified by the unique index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void RemoveControl(
	int index
)
Visual Basic
Public Sub RemoveControl ( _
	index As Integer _
)
Visual C++
public:
void RemoveControl(
	int index
)

Parameters

index
Type: SystemInt32
Unique index of the control to be deleted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.

See Also