SetAction Method


Changes the double-click action associated with a specified target.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public void SetAction(
	DoubleClickTarget target,
	DoubleClickAction action
)
Visual Basic
Public Sub SetAction ( _
	target As DoubleClickTarget, _
	action As DoubleClickAction _
)
Visual C++
public:
void SetAction(
	DoubleClickTarget target, 
	DoubleClickAction action
)

Parameters

target
Type: Autodesk.Revit.UIDoubleClickTarget
The double-click target whose action will be changed.
action
Type: Autodesk.Revit.UIDoubleClickAction
The action to assign to the target.

Remarks

This change will be stored in the user's profile and will affect future sessions of Revit in addition to the current session.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The specified action is not valid for the target element.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also