SetAction Method


Double Click Options Set Action Method

Changes the double-click action associated with a specified target.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetAction(
	DoubleClickTarget target,
	DoubleClickAction action
)

Parameters

target DoubleClickTarget
The double-click target whose action will be changed.
action DoubleClickAction
The action to assign to the target.
Exceptions
Exception Condition
ArgumentException The specified action is not valid for the target element.
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
This change will be stored in the user's profile and will affect future sessions of Revit in addition to the current session.
See Also