CreateReferenceElevation Method


Creates a reference elevation on the ElevationMarker at the desired index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void CreateReferenceElevation(
	Document document,
	int index,
	ElementId viewIdToReference
)
Visual Basic
Public Sub CreateReferenceElevation ( _
	document As Document, _
	index As Integer, _
	viewIdToReference As ElementId _
)
Visual C++
public:
void CreateReferenceElevation(
	Document^ document, 
	int index, 
	ElementId^ viewIdToReference
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to which the new reference elevation will be added.
index
Type: SystemInt32
The index on the ElevationMarker where the reference elevation will be placed.
viewIdToReference
Type: Autodesk.Revit.DBElementId
The view which will be referenced.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId viewIdToReference does not correspond to a View. -or- This view cannot be referenced by elevations. -or- index is occupied or out of range. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Only reference elevations can be hosted on this ElevationMarker.
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also