Elevation |
Creates a reference elevation on the ElevationMarker at the desired index.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void CreateReferenceElevation(
Document document,
int index,
ElementId viewIdToReference
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- This view cannot be referenced by elevations. -or- index is occupied or out of range. -or- Elevation view creation is not allowed in this family. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Only reference elevations can be hosted on this ElevationMarker. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |