CreateRecommendedTypeForSet Method


Creates an element type recommended for alignment label sets and returns its ElementId.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021.1

Syntax

C#
public static ElementId CreateRecommendedTypeForSet(
	Document document
)
Visual Basic
Public Shared Function CreateRecommendedTypeForSet ( _
	document As Document _
) As ElementId
Visual C++
public:
static ElementId^ CreateRecommendedTypeForSet(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which the type will be created.

Remarks

The crucial features of the label type recommended for sets are: - rotate with component - vertical text - label display includes station value - leader arrow head has type "Heavy End Tick Mark"

See Also