CreateRecommendedTypeForSet Method


Alignment Station Label Create Recommended Type For Set Method

Creates an element type recommended for alignment label sets and returns its ElementId.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId CreateRecommendedTypeForSet(
	Document document
)

Parameters

document Document
The document in which the type will be created.

Return Value

ElementId
Remarks
The crucial features of the label type recommended for sets are: - rotate with component - vertical text - label display includes station value - leader arrow head has type "Heavy End Tick Mark"
See Also