TabbedDialogExtension Constructor


Constructs a extension instance with a control and ok action handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public TabbedDialogExtension(
	UserControl userControl,
	TabbedDialogAction onOK
)
Visual Basic
Public Sub New ( _
	userControl As UserControl, _
	onOK As TabbedDialogAction _
)
Visual C++
public:
TabbedDialogExtension(
	UserControl^ userControl, 
	TabbedDialogAction^ onOK
)

Parameters

userControl
Type: System.Windows.ControlsUserControl
The control.
onOK
Type: Autodesk.Revit.UITabbedDialogAction
The ok action handler.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when userControl or onOK is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionThrown when userControl is already bound to another tabbed dialog.

See Also