TabbedDialogExtension Constructor


Tabbed Dialog Extension Constructor

Constructs a extension instance with a control and ok action handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TabbedDialogExtension(
	UserControl userControl,
	TabbedDialogAction onOK
)

Parameters

userControl UserControl
The control.
onOK TabbedDialogAction
The ok action handler.
Exceptions
Exception Condition
ArgumentNullException Thrown when userControl or onOK is .
ArgumentException Thrown when userControl is already bound to another tabbed dialog.
See Also