GetShownAttachedDetailGroupTypeIds Method


Returns the attached detail groups which have displayed instances for this group type in the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2019.1

Syntax

C#
public ISet<ElementId> GetShownAttachedDetailGroupTypeIds(
	View view
)
Visual Basic
Public Function GetShownAttachedDetailGroupTypeIds ( _
	view As View _
) As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetShownAttachedDetailGroupTypeIds(
	View^ view
)

Parameters

view
Type: Autodesk.Revit.DBView
The view in which the attached detail groups are displayed.

Return Value

The collection of attached detail group Ids that match this group's type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The input group is not a model group and can therefore not have attached detail groups.

See Also