GetShownAttachedDetailGroupTypeIds Method


Group Get Shown Attached Detail Group Type Ids Method

Returns the attached detail groups which have displayed instances for this group type in the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ISet<ElementId> GetShownAttachedDetailGroupTypeIds(
	View view
)

Parameters

view View
The view in which the attached detail groups are displayed.

Return Value

ISet ElementId
The collection of attached detail group Ids that match this group's type.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The input group is not a model group and can therefore not have attached detail groups.
See Also