Checks that the hook angle of the specified RebarHookType matches the hook angle used in the Rebar's RebarShape at the specified end of the bar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- iEnd
- Type: SystemInt32
0 for the start hook, 1 for the end hook.
- proposedHookId
- Type: Autodesk.Revit.DBElementId
The Id of the RebarHookType
Return Value
Returns true if the hook angle of the RebarHookType matches the angle used in the RebarShape at the specified end of the bar.Remarks
Also checks that the specified id is a valid RebarHookType. If RebarShapeDefinesHooks property of ReinforcementSettings is false (European shapes), every valid hook angle matches RebarShape definition. If RebarShapeDefinesHooks property of ReinforcementSettings is true (non-European shapes), hook angle matches RebarShape definition if it is null or equal RebarShape default hook angle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | iEnd must be 0 or 1. |