HookAngleMatchesRebarShapeDefinition Method


Rebar Hook Angle Matches Rebar Shape Definition Method

Checks that the hook angle of the specified RebarHookType matches the hook angle used in the Rebar's RebarShape at the specified end of the bar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool HookAngleMatchesRebarShapeDefinition(
	int end,
	ElementId proposedHookId
)

Parameters

end Int32
0 for the start hook, 1 for the end hook.
proposedHookId ElementId
The Id of the RebarHookType

Return Value

Boolean
Returns true if the hook angle of the RebarHookType matches the angle used in the RebarShape at the specified end of the bar.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException end must be 0 or 1.
Remarks
Also checks that the specified id is a valid RebarHookType. If RebarShapeDefinesHooks property of ReinforcementSettings is false (European shapes), every valid hook angle matches RebarShape definition. If RebarShapeDefinesHooks property of ReinforcementSettings is true (non-European shapes), hook angle matches RebarShape definition if it is null or equal RebarShape default hook angle.
See Also