ExternallyTaggedNonBRep Constructor


Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public ExternallyTaggedNonBRep(
	ExternalGeometryId externalId,
	GeometryObject geometry
)
Visual Basic
Public Sub New ( _
	externalId As ExternalGeometryId, _
	geometry As GeometryObject _
)
Visual C++
public:
ExternallyTaggedNonBRep(
	ExternalGeometryId^ externalId, 
	GeometryObject^ geometry
)

Parameters

externalId
Type: Autodesk.Revit.DBExternalGeometryId
The Id of the input geometry object.
geometry
Type: Autodesk.Revit.DBGeometryObject
The externally tagged geometry object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException geometry must not be a Solid. -or- geometry must not have sub-nodes.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also