ExternallyTaggedNonBRep Constructor


Externally Tagged Non BRep Constructor

Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExternallyTaggedNonBRep(
	ExternalGeometryId externalId,
	GeometryObject geometry
)

Parameters

externalId ExternalGeometryId
The Id of the input geometry object.
geometry GeometryObject
The externally tagged geometry object.
Exceptions
Exception Condition
ArgumentException geometry must not be a Solid. -or- geometry must not have sub-nodes.
ArgumentNullException A non-optional argument was null
See Also