ElementId Constructor (Int32)


Create an ElementId handle with the given 32-bit integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")]
public ElementId(
	int id
)
Visual Basic
<ObsoleteAttribute("This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")> _
Public Sub New ( _
	id As Integer _
)
Visual C++
[ObsoleteAttribute(L"This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")]
public:
ElementId(
	int id
)

Parameters

id
Type: System Int32
The id.

See Also