Print Method (ViewSet)


Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print(
	ViewSet views
)
Visual Basic
Public Sub Print ( _
	views As ViewSet _
)
Visual C++
public:
void Print(
	ViewSet^ views
)

Parameters

views
Type: Autodesk.Revit.DBViewSet
The set of views which need to be printed.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when the view set to be printed is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionThrown when the view set contains a a null reference (Nothing in Visual Basic) element.
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when at least one view from the view set could not be printed.
Autodesk.Revit.ExceptionsOperationCanceledExceptionThrown when print is cancelled by event handler.

See Also