Print Method (ViewSet)


Document Print(View Set) Method

Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Print(
	ViewSet views
)

Parameters

views ViewSet
The set of views which need to be printed.
Exceptions
Exception Condition
InvalidOperationException Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
ArgumentNullException Thrown when the view set to be printed is .
ArgumentException Thrown when the view set contains a element.
InvalidOperationException Thrown when at least one view from the view set could not be printed.
OperationCanceledException Thrown when print is cancelled by event handler.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
See Also