SharedParameterApplicableRule Constructor


Constructs an instance of SharedParameterApplicableRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public SharedParameterApplicableRule(
	string parameterName
)
Visual Basic
Public Sub New ( _
	parameterName As String _
)
Visual C++
public:
SharedParameterApplicableRule(
	String^ parameterName
)

Parameters

parameterName
Type: SystemString
The name of the parameter that an element must support to pass this rule.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also