SetMapOfSizesForStraights Method


Set the mapping for sizes of fabrication part straights to change the sizes to.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.2

Syntax

C#
public void SetMapOfSizesForStraights(
	ISet<FabricationPartSizeMap> fabricationPartSizeMaps
)
Visual Basic
Public Sub SetMapOfSizesForStraights ( _
	fabricationPartSizeMaps As ISet(Of FabricationPartSizeMap) _
)
Visual C++
public:
void SetMapOfSizesForStraights(
	ISet<FabricationPartSizeMap^>^ fabricationPartSizeMaps
)

Parameters

fabricationPartSizeMaps
Type: System.Collections.GenericISetFabricationPartSizeMap
The map containing the original straights size to the mapped sizes.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also