Fabrication |
Set the mapping for sizes of fabrication part straights to change the sizes to.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetMapOfSizesForStraights(
ISet<FabricationPartSizeMap> fabricationPartSizeMaps
)
Parameters
- fabricationPartSizeMaps ISet FabricationPartSizeMap
- The map containing the original straights size to the mapped sizes.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |