Efficacy Property


The efficacy value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public double Efficacy { get; set; }
Visual Basic
Public Property Efficacy As Double
	Get
	Set
Visual C++
public:
property double Efficacy {
	double get ();
	void set (double value);
}

Field Value

The efficacy value in lm/W as a numerical value greater than 0.0 and less than 1.0e+10.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The efficacy value is not valid because it is not between 0 and 1e+30.

See Also