FindTypeByName Method


Finds the analytical connection type by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static ElementId FindTypeByName(
	Document doc,
	string name
)
Visual Basic
Public Shared Function FindTypeByName ( _
	doc As Document, _
	name As String _
) As ElementId
Visual C++
public:
static ElementId^ FindTypeByName(
	Document^ doc, 
	String^ name
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document where the analytical conneciton type is expected.
name
Type: SystemString
The name of the expected analytical connection type.

Return Value

The element id of matched analytical connection type, otherwise invalidElementId.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException name is an empty string.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also