FindTypeByName Method


MEPAnalytical Connection Type Find Type By Name Method

Finds the analytical connection type by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId FindTypeByName(
	Document doc,
	string name
)

Parameters

doc Document
The document where the analytical conneciton type is expected.
name String
The name of the expected analytical connection type.

Return Value

ElementId
The element id of matched analytical connection type, otherwise invalidElementId.
Exceptions
Exception Condition
ArgumentException name is an empty string.
ArgumentNullException A non-optional argument was null
See Also