Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFCExporterIFC
The exporter.
- geometryInfo
- Type: Autodesk.Revit.DB.IFCIFCGeometryInfo
The container object which collects the geometry.
- gNode
- Type: Autodesk.Revit.DBGeometryObject
The geometry object to be processed.
- offset
- Type: Autodesk.Revit.DBXYZ
The offset to apply to each of the collected geometry handles.
- forceVisible
- Type: SystemBoolean
True to process geometry which is not set as visible. False to only process visible geometry.
Remarks
The type of geometry collected is determined by the method of creation for the IFCGeometryInfo.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |