Exporter |
Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static void CollectGeometryInfo(
ExporterIFC exporterIFC,
IFCGeometryInfo geometryInfo,
GeometryObject gNode,
XYZ offset,
bool forceVisible
)
Parameters
- exporterIFC ExporterIFC
- The exporter.
- geometryInfo IFCGeometryInfo
- The container object which collects the geometry.
- gNode GeometryObject
- The geometry object to be processed.
- offset XYZ
- The offset to apply to each of the collected geometry handles.
- forceVisible Boolean
- True to process geometry which is not set as visible. False to only process visible geometry.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The type of geometry collected is determined by the method of creation for the IFCGeometryInfo.