MoveElements Method


Moves a set of elements by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static void MoveElements(
	Document document,
	ICollection<ElementId> elementsToMove,
	XYZ translation
)
Visual Basic
Public Shared Sub MoveElements ( _
	document As Document, _
	elementsToMove As ICollection(Of ElementId), _
	translation As XYZ _
)
Visual C++
public:
static void MoveElements(
	Document^ document, 
	ICollection<ElementId^>^ elementsToMove, 
	XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document that owns the elements.
elementsToMove
Type: System.Collections.GenericICollectionElementId
The set of elements to move.
translation
Type: Autodesk.Revit.DBXYZ
The translation vector for the elements.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given element id set is empty. -or- One or more elements in elementsToMove do not exist in the document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException If we are not able to move all the elements (for example, if one or more elements is pinned). -or- Move operation failed.

See Also