MoveElements Method


Element Transform Utils Move Elements Method

Moves a set of elements by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void MoveElements(
	Document document,
	ICollection<ElementId> elementsToMove,
	XYZ translation
)

Parameters

document Document
The document that owns the elements.
elementsToMove ICollection ElementId
The set of elements to move.
translation XYZ
The translation vector for the elements.
Exceptions
Exception Condition
ArgumentException The given element id set is empty. -or- One or more elements in elementsToMove do not exist in the document.
ArgumentNullException A non-optional argument was null
InvalidOperationException If we are not able to move all the elements (for example, if one or more elements is pinned). -or- Move operation failed.
See Also