CanHaveTypeAssigned Method (Document, ICollection(ElementId))


Checks if all elements in the set can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool CanHaveTypeAssigned(
	Document document,
	ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function CanHaveTypeAssigned ( _
	document As Document, _
	elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanHaveTypeAssigned(
	Document^ document, 
	ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
elementIds
Type: System.Collections.GenericICollectionElementId
A collection of element IDs.

Return Value

True if all elements in the set can have a type assigned, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also