Element Can |
Checks if all elements in the set can have a type assigned.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool CanHaveTypeAssigned(
Document document,
ICollection<ElementId> elementIds
)
Parameters
- document Document
- The document.
- elementIds ICollection ElementId
- A collection of element IDs.
Return Value
BooleanTrue if all elements in the set can have a type assigned, false otherwise.

Exception | Condition |
---|---|
ArgumentException | Thrown when at least one of the elements does not exist in the document. |
ArgumentNullException | A non-optional argument was null |