SetPointConstraintType Method


Sets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static void SetPointConstraintType(
	Document doc,
	ElementId refPointId,
	AdaptivePointConstraintType constraintType
)
Visual Basic
Public Shared Sub SetPointConstraintType ( _
	doc As Document, _
	refPointId As ElementId, _
	constraintType As AdaptivePointConstraintType _
)
Visual C++
public:
static void SetPointConstraintType(
	Document^ doc, 
	ElementId^ refPointId, 
	AdaptivePointConstraintType constraintType
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The Document
refPointId
Type: Autodesk.Revit.DBElementId
The ReferencePoint id
constraintType
Type: Autodesk.Revit.DBAdaptivePointConstraintType
Constraint type of the Adaptive Shape Handle Point.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This operation failed.

See Also