Adaptive |
Sets constrain type of an Adaptive Shape Handle Point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static void SetPointConstraintType(
Document doc,
ElementId refPointId,
AdaptivePointConstraintType constraintType
)
Parameters
- doc Document
- The Document
- refPointId ElementId
- The ReferencePoint id
- constraintType AdaptivePointConstraintType
- Constraint type of the Adaptive Shape Handle Point.

Exception | Condition |
---|---|
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | This operation failed. |