Enumerates all the sketch options.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
SGO_Default | The default option which means the real option is decided by Revit internally. |
SGO_Line | Sketch a line. |
SGO_Rect | Sketch a rectangle. |
SGO_InscribedPolygon | Sketch an inscribed polygon. |
SGO_CircumscribedPolygon | Sketch a circumscribed polygon. |
SGO_Circle | Sketch a circle. |
SGO_Arc3Point | Sketch a Start-End-Radius arc. |
SGO_ArcCenterEnds | Sketch a Center-Ends arc. |
SGO_ArcTanEnd | Sketch a Tangent-End arc. |
SGO_ArcFillet | Sketch a fillet arc. |
SGO_Spline | Sketch a spline. |
SGO_SplineByPoints | Sketch a spline by points. |
SGO_FullEllipse | Sketch a full ellipse. |
SGO_PartialEllipse | Sketch a partial ellipse. |
SGO_PickLines | Pick lines. |
SGO_PickFaces | Pick faces. |
SGO_PickWalls | Pick walls. |
SGO_PickSupports | Pick supports. |
SGO_PickRoofs | Pick roofs. |
SGO_Point | Pick a point. |
SGO_PickPoints | Pick points. |
SGO_PointElement | Pick point element. |
SGO_RunLine | Sketch a line for a run of stairs. |
SGO_RunArcFullStep | Sketch a Full-Step spiral for a run of stairs. |
SGO_RunArcCenterEnds | Sketch a Center-Ends spiral for a run of stairs. |
SGO_LandingSquare | Sketch a landing square. |
SGO_WinderLShape | Sketch a L-Shape winder. |
SGO_WinderPattern | Pick winder pattern. |
SGO_SupportPickLine | Pick a line to create a support. |
SGO_WinderUShape | Sketch a U-Shape winder. |
SGO_LandingWithTwoRuns | Pick two runs to create a landing. |
SGO_SketchRun | Sketch a run. |
SGO_SketchLanding | Sketch a landing. |