Sketch |
Enumerates all the sketch options.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)


Member name | Value | Description |
---|---|---|
SGO_Default | 0 | The default option which means the real option is decided by Revit internally. |
SGO_Line | 1 | Sketch a line. |
SGO_Rect | 2 | Sketch a rectangle. |
SGO_InscribedPolygon | 3 | Sketch an inscribed polygon. |
SGO_CircumscribedPolygon | 4 | Sketch a circumscribed polygon. |
SGO_Circle | 5 | Sketch a circle. |
SGO_Arc3Point | 6 | Sketch a Start-End-Radius arc. |
SGO_ArcCenterEnds | 7 | Sketch a Center-Ends arc. |
SGO_ArcTanEnd | 8 | Sketch a Tangent-End arc. |
SGO_ArcFillet | 9 | Sketch a fillet arc. |
SGO_Spline | 10 | Sketch a spline. |
SGO_SplineByPoints | 11 | Sketch a spline by points. |
SGO_FullEllipse | 12 | Sketch a full ellipse. |
SGO_PartialEllipse | 13 | Sketch a partial ellipse. |
SGO_PickLines | 14 | Pick lines. |
SGO_PickFaces | 15 | Pick faces. |
SGO_PickWalls | 16 | Pick walls. |
SGO_PickSupports | 17 | Pick supports. |
SGO_PickRoofs | 18 | Pick roofs. |
SGO_Point | 19 | Pick a point. |
SGO_PickPoints | 20 | Pick points. |
SGO_PointElement | 21 | Pick point element. |
SGO_RunLine | 22 | Sketch a line for a run of stairs. |
SGO_RunArcFullStep | 23 | Sketch a Full-Step spiral for a run of stairs. |
SGO_RunArcCenterEnds | 24 | Sketch a Center-Ends spiral for a run of stairs. |
SGO_LandingSquare | 25 | Sketch a landing square. |
SGO_WinderLShape | 26 | Sketch a L-Shape winder. |
SGO_WinderPattern | 27 | Pick winder pattern. |
SGO_SupportPickLine | 28 | Pick a line to create a support. |
SGO_WinderUShape | 29 | Sketch a U-Shape winder. |
SGO_LandingWithTwoRuns | 30 | Pick two runs to create a landing. |
SGO_SketchRun | 31 | Sketch a run. |
SGO_SketchLanding | 32 | Sketch a landing. |