GetLabelFor Method (gbXMLBuildingType, Document)


Gets the user-visible name for a gbXMLBuildingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static string GetLabelFor(
	gbXMLBuildingType buildingType,
	Document document
)
Visual Basic
Public Shared Function GetLabelFor ( _
	buildingType As gbXMLBuildingType, _
	document As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
	gbXMLBuildingType buildingType, 
	Document^ document
)

Parameters

buildingType
Type: Autodesk.Revit.DB.AnalysisgbXMLBuildingType
The gbXMLBuildingType to get the user-visible name.
document
Type: Autodesk.Revit.DBDocument
The document from which to get the gbXMLBuildingType.

Remarks

The name is obtained in the current Revit language.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input gXMLBuildingType is not available in the document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also