Label |
Gets the user-visible name for a gbXMLBuildingType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- buildingType gbXMLBuildingType
- The gbXMLBuildingType to get the user-visible name.
- document Document
- The document from which to get the gbXMLBuildingType.
Return Value
String
Exception | Condition |
---|---|
ArgumentException | The input gXMLBuildingType is not available in the document. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

The name is obtained in the current Revit language.