GetDefaultFloorType Method


Returns id of default floor type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static ElementId GetDefaultFloorType(
	Document document,
	bool isFoundation
)
Visual Basic
Public Shared Function GetDefaultFloorType ( _
	document As Document, _
	isFoundation As Boolean _
) As ElementId
Visual C++
public:
static ElementId^ GetDefaultFloorType(
	Document^ document, 
	bool isFoundation
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
isFoundation
Type: SystemBoolean
True to return id of foundation floor type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also