Checks whether a railing can be created along a railing path.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveLoop
- Type: Autodesk.Revit.DBCurveLoop
The railing path along which the new railing will be created.
Return Value
True if the new railing path can be used in a railing definition, False otherwise.Remarks
The railing path should be located on the same horizontal plane and it should contain lines or arcs only. It also has to be continuous and its three or more curves cannot meet in one end point.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |