Railing Is |
Checks whether a railing can be created along a railing path.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- curveLoop CurveLoop
- The railing path along which the new railing will be created.
Return Value
BooleanTrue if the new railing path can be used in a railing definition, False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The railing path should be located on the same horizontal plane and it should contain lines or arcs only. It also has to be continuous and its three or more curves cannot meet in one end point.