LineLightShape Class


This class encapsulates a line light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public class LineLightShape : LightShape
Visual Basic
Public Class LineLightShape _
	Inherits LightShape
Visual C++
public ref class LineLightShape : public LightShape

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DB.LightingLightShape
    Autodesk.Revit.DB.LightingLineLightShape

See Also