LineLightShape Class


Line Light Shape Class

This class encapsulates a line light shape.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting LineLightShape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LineLightShape : LightShape

The LineLightShape type exposes the following members.

Constructors
Name Description
Public method LineLightShape Creates a line light shape object with 2.0' emit length.
Public method LineLightShape(Double) Creates a line light shape object with the given emit length.
Public method LineLightShape(LineLightShape) Creates a copy of the given line light shape
Top
Properties
Name Description
Public property EmitLength The emit length.
Top
Methods
Name Description
Top
See Also