LineLightShape Class


Line Light Shape Class

This class encapsulates a line light shape.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting LineLightShape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LineLightShape : LightShape

The LineLightShape type exposes the following members.

Constructors
Name Description
Public method LineLightShape Creates a line light shape object with 2.0' emit length.
Public method LineLightShape(Double) Creates a line light shape object with the given emit length.
Public method LineLightShape(LineLightShape) Creates a copy of the given line light shape
Top
Properties
Name Description
Public property EmitLength The emit length.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from LightShape )
Top
Methods
Name Description
Public method Clone Creates a copy of the LightShape derived object.
(Inherited from LightShape )
Public method Dispose
(Inherited from LightShape )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also