CreateBlendGeometry Method (CurveLoop, CurveLoop, ICollection(VertexPair), SolidOptions)


Creates a solid by blending two closed curve loops lying in non-coincident planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static Solid CreateBlendGeometry(
	CurveLoop firstLoop,
	CurveLoop secondLoop,
	ICollection<VertexPair> vertexPairs,
	SolidOptions solidOptions
)
Visual Basic
Public Shared Function CreateBlendGeometry ( _
	firstLoop As CurveLoop, _
	secondLoop As CurveLoop, _
	vertexPairs As ICollection(Of VertexPair), _
	solidOptions As SolidOptions _
) As Solid
Visual C++
public:
static Solid^ CreateBlendGeometry(
	CurveLoop^ firstLoop, 
	CurveLoop^ secondLoop, 
	ICollection<VertexPair^>^ vertexPairs, 
	SolidOptions^ solidOptions
)

Parameters

firstLoop
Type: Autodesk.Revit.DBCurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
secondLoop
Type: Autodesk.Revit.DBCurveLoop
The second curve loop, satisfying the same conditions as the first loop. The planes of the first and second loops must not be coincident, but they need not be parallel.
vertexPairs
Type: System.Collections.GenericICollectionVertexPair
This input specifies how the two profile loops should be connected. If null, the function chooses vertex connections that will result in a geometrically reasonable blend.
solidOptions
Type: Autodesk.Revit.DBSolidOptions
The optional information to control the properties of the Solid.

Return Value

The requested solid.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The first profile CurveLoop do not satisfy the input requirements. -or- The second profile CurveLoop do not satisfy the input requirements.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also