AddItems Method


Adds a new items to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<ComboBoxMember> AddItems(
	IList<ComboBoxMemberData> memberData
)
Visual Basic
Public Function AddItems ( _
	memberData As IList(Of ComboBoxMemberData) _
) As IList(Of ComboBoxMember)
Visual C++
public:
IList<ComboBoxMember^>^ AddItems(
	IList<ComboBoxMemberData^>^ memberData
)

Parameters

memberData
Type: System.Collections.GenericIListComboBoxMemberData
An object list containing the data needed to construct the ComboBoxMember.

Return Value

The newly added ComboBoxMembers.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when memberData is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when button with memberData.Name already exists in the drop-down list.

See Also