AddItems Method


Combo Box Add Items Method

Adds a new items to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ComboBoxMember> AddItems(
	IList<ComboBoxMemberData> memberData
)

Parameters

memberData IList ComboBoxMemberData
An object list containing the data needed to construct the ComboBoxMember.

Return Value

IList ComboBoxMember
The newly added ComboBoxMembers.
Exceptions
Exception Condition
ArgumentNullException Thrown when memberData is .
ArgumentException Thrown when button with memberData.Name already exists in the drop-down list.
See Also