AddFace Method


Adds a face to the currently open connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public void AddFace(
	TessellatedFace face
)
Visual Basic
Public Sub AddFace ( _
	face As TessellatedFace _
)
Visual C++
public:
void AddFace(
	TessellatedFace^ face
)

Parameters

face
Type: Autodesk.Revit.DBTessellatedFace
Face to add. The 'face' parameter can be added only once, as its boundary loops will be cleared while adding and 'face' will become unusable.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The 'face' does not have enough loops and/or vertices to be valid.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException A face set is closed and faces cannot be added to it.

See Also